package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(@.+?)\s+?(.*)$`)
var str = `@villos hey dude
Ÿ³é‡ï¼Ÿã€€åˆã‚ã¦çŸ¥ã‚Šã¾ã—ãŸã€‚ shiftã—ãªãŒã‚‰ã‚¨ã‚¯ã‚¹ãƒ
@tester testing 123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}