re = /^(@.+?)\s+?(.*)$/m
str = '@villos hey dude
Ÿ³é‡ï¼Ÿã€€åˆã‚ã¦çŸ¥ã‚Šã¾ã—ãŸã€‚ shiftã—ãªãŒã‚‰ã‚¨ã‚¯ã‚¹ãƒ
@tester testing 123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end