using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\s)\(?#(\w+)\)?";
string input = @"(#lolz wow)
(LOL #cool)
(#cool)
(ex. #lolz but not hsshs#jdjd)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}