re = /(?<=^|\s)\(?#(\w+)\)?/
str = '(#lolz wow)
(LOL #cool)
(#cool)
(ex. #lolz but not hsshs#jdjd)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end