using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\s\w{3,}|\w{3,}\s\d+";
string input = @"12 abc
1 abc
abc 1
abcde 12
ab 1
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}