$re = '/\d+\s\w{3,}|\w{3,}\s\d+/';
$str = '12 abc
1 abc
abc 1
abcde 12
ab 1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);