#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z]+(?![^{]*\})"
Local $sString = "{con}descens{ion}" & @CRLF & _
"lumberjack" & @CRLF & _
"tim{ing}" & @CRLF & _
"{tox}{icity}" & @CRLF & _
"fish" & @CRLF & _
"{dis}pel"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")