re = /[a-zA-Z]+(?![^{]*\})/
str = '{con}descens{ion}
lumberjack
tim{ing}
{tox}{icity}
fish
{dis}pel'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end