const regex = new RegExp('(?P<block>(?P<subject>[A-Z]{2,12})(?:(?P<operation>\\*|\\+)(?P<value>\\d+(?:.?\\d{1,2})?))?)', 'g')
const str = `JK+6.00,PP*2,ZZ,GROUPO`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}