re = /(?P<block>(?P<subject>[A-Z]{2,12})(?:(?P<operation>\*|\+)(?P<value>\d+(?:.?\d{1,2})?))?)/
str = 'JK+6.00,PP*2,ZZ,GROUPO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end