# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Regular Expression"
test_str = ("A U F G A B E\n"
"Finden Sie alle Hinweise auf Fußnoten (\"zur Fussnote\") im Text.\n\n"
"Textquelle: Kollmann, in: Dauner-Lieb/Langen, § 305 Rn. 10f.\n\n"
"T E X T:\n"
"Vertragsbedingungen sind vorformuliert, wenn sie vor Vertragsabschluss bereits fertig aufgestellt sind. Dazu müssen sie auf irgendeine Weise gespeichert oder niedergelegt sein, wozu auch ein Vorsprechen aus dem Gedächtnis genügt.\n"
"zur Fussnote\n"
"[1] Nach Ansicht des BGH genügt es zudem, wenn bei den Klauseln „im Wesentlichen eine Gleichartigkeit“ vorliegt, Klauseln zB auf die konkrete Situation angepasst (also durchaus individuell) sind\n"
"zur Fussnote\n"
"[2] (s.a. Rn 42). Das OLG München hat es sogar genügen lassen, dass Klauseln „sinngemäß“ in anderen Fällen verwendet werden.\n"
"zur Fussnote\n"
"[3] Die Folgen einer solchen Rechtsprechung wären allerdings verheerend, weil etwa Gewährleistungs- oder Haftungsklauseln naturgemäß immer etwas „Sinngemäßes“ aus anderen Verträgen beinhalten und auch zwischen Verwendern nicht sehr unterschiedlich formuliert werden (können), wenn man in rechtssicherer Weise ein bestimmtes Ziel umsetzen will. Diese Forderungen gehen an den berechtigten Bedürfnissen der Praxis vorbei.\n"
"Randnummer\n"
"11\n"
"Das Merkmal „für eine Vielzahl von Verträgen“ erfordert, dass die Absicht der Mehrfachverwendung im Zeitpunkt des Vertragsabschlusses\n"
"zur Fussnote\n"
"[4] besteht. Mehrfach bedeutet: mindestens dreifach.\n"
"zur Fussnote\n"
"[5] Die Verwendung gegenüber mehreren Bietern/Interessenten zum Abschluss nur eines Vertrags ist aber keine Mehrfachverwendung.\n"
"zur Fussnote\n"
"[6] Umgekehrt genügt es, wenn die Mehrfachverwendung sogar gegenüber demselben Partner (aber für verschiedene Verträge) erfolgt bzw erfolgen soll.\n"
"zur Fussnote\n"
"[7] Hiervon abzugrenzen sind interne Muster (s. Rn 12) und Arbeitsanweisungen, die allenfalls bei tatsächlicher Verwendung (mit Mehrfachverwendungsabsicht) zu AGB werden\n"
"zur Fussnote\n"
"[8] (s.a. § 306 a Rn 3 zur Umgehung). Eine Vermutung für die Mehrfachverwendungs-Absicht besteht, wenn die fragliche Klausel vom Verwender tatsächlich mehrfach\n"
"zur Fussnote\n"
"[9] verwendet wurde oder der äußeren Form nach auf diese Absicht schließen lässt (s. Rn 42). Die Mehrfachverwendung muss zudem in einem überschaubaren Zeitraum erfolgen, wobei sieben Jahre Abstand zu lang sind.\n"
"zur Fussnote\n"
"[10] (Die tatsächliche Mehrfachverwendung ist umgekehrt aber keine Voraussetzung für das Vorliegen von AGB.) Die Absicht zur Mehrfachverwendung kann auch aus sonstigen Umständen geschlossen werden, zB der Planmäßigkeit im Vorgehen des Verwenders.\n"
"zur Fussnote\n"
"[11] Es ist auch nicht erforderlich, dass der Verwender die Klausel vorformuliert hat. So genügt es bei (externen) Mustern und häufiger verwendeten Klauseln, wenn der aufstellende Dritte die Mehrfachverwendungs-Absicht hatte.\n"
"zur Fussnote\n"
"[12] Beispiel: Verbands-Muster bzw Verbands-AGB.\n"
"zur Fussnote\n"
"[13] Zur VOB/B: s. Rn 133 ff. Die Regelungen eines mehrfach verwendeten Verhandlungsprotokolls stellen oft AGB dar; wird darin formularmäßig auf ein anderes Dokument (zB den „Kundenvertrag“) verwiesen, so sind die Regelungen dieser anderen Unterlage (zB des Kundenvertrages) aber nicht allein deshalb AGB (sondern nur, wenn der Verwender seinerseits mehrfach auf diese Regelungen verweist – zB gegenüber mehreren Subunternehmern).\n"
"zur Fussnote\n"
"[14] Zur Umgehung durch interne Bankanweisung: § 306 a Rn 3.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.