using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]{1,2}\d{1,2})\s*?(\d[a-zA-Z]{2})$";
string input = @"m20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}