const regex = /folder1\/userlist\.php.+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('folder1\\\/userlist\\.php.+', '')
const str = `folder1/userlist.php?username=&show_group=-1&sort_by=username&sort_dir=ASC&p=45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}