$re = '/folder1\/userlist\.php.+/';
$str = 'folder1/userlist.php?username=&show_group=-1&sort_by=username&sort_dir=ASC&p=45';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);