using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:([aeiou])(?!.{1,2}\1)){3}";
string input = @"abcaeifoo
mnoiouxyz
foobar
aiepqra
aia
aiea";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}