$re = '/(?:([aeiou])(?!.{1,2}\1)){3}/m';
$str = 'abcaeifoo
mnoiouxyz
foobar
aiepqra
aia
aiea';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);