import Foundation
let pattern = #"(\([^)]+\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #".com registration (domain.com)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)