package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^)]+\))\s+\(([^)]+)\)`)
var str = `Hello Smith (STL Terminal) (15.0) i`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}