re = /severity\"(?!info)/i
str = 'severity="info"
severity="warning"'
subst = '|ISNI=$1 $2 $3 $4$5'
result = str.sub(re, subst)
# Print the result of the substitution
puts result