const regex = new RegExp('(&)[aeoz](uml)', 'gm')
const str = `ä
&zuml
ö
ë
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);