use strict;
my $str = 'ä
&zuml
ö
ë
';
my $regex = qr/(&)[aeoz](uml)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";