package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z]{2,}-?[0-9]{2,})`)
var str = `AK-747 AK747`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}