$re = '/([A-Z]{2,}-?[0-9]{2,})/';
$str = 'AK-747 AK747';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);