import re
regex = re.compile(r"^\x3a(?::?(?:\[\w+\])?(?:\[\s\w+\s\]?)?)?\s?(\w+)", flags=re.IGNORECASE | re.MULTILINE)
test_str = (":[ Admin ] User_name\n"
":[gold][ Admin ] User_name\n"
":[gold]User_name\n"
":[gold][ Admin ] user_name\n"
":User_name")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")