$re = '/^\p{Ps}(\X+?)\p{Pe}\X+\p{Pe}([^\p{Pe}]+)$/';
$str = '(الْبَين) الْوَاضِح والطلق اللِّسَان الفصيح (ج) أبيناء وبيناء وأبيان
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);