import Foundation
let pattern = #"^\p{Ps}(\X+?)\p{Pe}\X+\p{Pe}([^\p{Pe}]+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(الْبَين) الْوَاضِح والطلق اللِّسَان الفصيح (ج) أب يناء وبيناء وأبيان
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}