#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!^\s*)\s{2,}"
Local $sString = "One OS to rule them all," & @CRLF & _
" One OS to find them." & @CRLF & _
" One OS to call them all," & @CRLF & _
" And in salvation bind them." & @CRLF & _
" In the bright land of Linux," & @CRLF & _
" Where the hackers play."
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)