# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!^\s*)\s{2,}"
test_str = ("One OS to rule them all,\n"
" One OS to find them.\n"
" One OS to call them all,\n"
" And in salvation bind them.\n"
" In the bright land of Linux,\n"
" Where the hackers play.")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.