#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "href="([^"]+)""
Local $sString = " <!DOCTYPE html>" & @CRLF & _
" <html lang="fr">" & @CRLF & _
"" & @CRLF & _
" <head></head>" & @CRLF & _
" <body>" & @CRLF & _
" <div id="wm-ipp" class="" lang="en" style="display: block;"></div>" & @CRLF & _
" <!--" & @CRLF & _
"" & @CRLF & _
" BEGIN WAYBACK TOOLBAR INSERT " & @CRLF & _
"" & @CRLF & _
" -->" & @CRLF & _
" <script src="/static/js/disclaim-element.js" type="text/javascript"></script>" & @CRLF & _
" <script src="/static/js/graph-calc.js" type="text/javascript"></script>" & @CRLF & _
" <script src="/static/jflot/jquery.min.js" type="text/javascript"></script>" & @CRLF & _
" <script type="text/javascript"></script>" & @CRLF & _
" <style type="text/css"></style>" & @CRLF & _
" <script type="text/javascript"></script>" & @CRLF & _
" <!--" & @CRLF & _
"" & @CRLF & _
" END WAYBACK TOOLBAR INSERT " & @CRLF & _
"" & @CRLF & _
" -->" & @CRLF & _
" <header id="main_header">" & @CRLF & _
" <div class="header_content"></div>" & @CRLF & _
" </header>" & @CRLF & _
" <div id="main_content">" & @CRLF & _
" <div id="under_top_event"></div>" & @CRLF & _
" <div id="breadcrumbs"></div>" & @CRLF & _
" <div id="main_search"></div>" & @CRLF & _
" <div id="content">" & @CRLF & _
" <div id="page_test" class="home">" & @CRLF & _
" <div id="topline">" & @CRLF & _
" <h1>" & @CRLF & _
"" & @CRLF & _
" TESTS" & @CRLF & _
"" & @CRLF & _
" </h1>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="large_column left_column">" & @CRLF & _
" <a class="top" title="Lire le test : The Final Fantasy" href="/web/20121023121603/http://www.gameweb.fr/articles/test-65-the-final-fantasy-3ds-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 20px 0;"></div>" & @CRLF & _
" <a class="high" title="Lire le test : El Shaddai : Ascension of The Metatron" href="/web/20121023121603/http://www.gameweb.fr/articles/test-63-el-shaddai-ascension-of-the-metatron-ps3-page-opinion.html"></a>" & @CRLF & _
" <a class="high" title="Lire le test : Heroes of Ruin" href="/web/20121023121603/http://www.gameweb.fr/articles/test-62-heroes-of-ruin-3ds-page-opinion.html"></a>" & @CRLF & _
" <a class="high" title="Lire le test : Prototype 2" href="/web/20121023121603/http://www.gameweb.fr/articles/test-61-prototype-2-ps3-page-opinion.html"></a>" & @CRLF & _
" <a class="high" title="Lire le test : Rayman Origins" href="/web/20121023121603/http://www.gameweb.fr/articles/test-60-rayman-origins-ps3-page-opinion.html"></a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="medium_column right_column" style="padding-top: 70px;">" & @CRLF & _
" <a class="medium" title="Lire le test : Mass Effect 3" href="/web/20121023121603/http://www.gameweb.fr/articles/test-59-mass-effect-3-x360-page-opinion.html">" & @CRLF & _
" <span class="small title"></span>" & @CRLF & _
" <span class="put_score score"></span>" & @CRLF & _
" <span class="description"></span>" & @CRLF & _
" </a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Pandora's Tower" href="/web/20121023121603/http://www.gameweb.fr/articles/test-58-pandoras-tower-wii-page-opinion.html">" & @CRLF & _
" <span class="small title"></span>" & @CRLF & _
" <span class="put_score score"></span>" & @CRLF & _
" <span class="description"></span>" & @CRLF & _
" </a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : I am alive" href="/web/20121023121603/http://www.gameweb.fr/articles/test-57-i-am-alive-x360-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Silent hill downpour" href="/web/20121023121603/http://www.gameweb.fr/articles/test-56-silent-hill-downpour-ps3-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Naruto Storm Generations" href="/web/20121023121603/http://www.gameweb.fr/articles/test-55-naruto-storm-generations-x360-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Street Fighter x Tekken" href="/web/20121023121603/http://www.gameweb.fr/articles/test-54-street-fighter-x-tekken-ps3-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Ninja Gaiden 3" href="/web/20121023121603/http://www.gameweb.fr/articles/test-53-ninja-gaiden-3-ps3-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Asura's Wrath" href="/web/20121023121603/http://www.gameweb.fr/articles/test-52-asuras-wrath-ps3-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : The Last Story" href="/web/20121023121603/http://www.gameweb.fr/articles/test-51-the-last-story-wii-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Xenoblade" href="/web/20121023121603/http://www.gameweb.fr/articles/test-50-xenoblade-wii-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : SSX" href="/web/20121023121603/http://www.gameweb.fr/articles/test-48-ssx-ps3-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Syndicate" href="/web/20121023121603/http://www.gameweb.fr/articles/test-47-syndicate-pc-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Resident Evil Revelations" href="/web/20121023121603/http://www.gameweb.fr/articles/test-46-resident-evil-revelations-3ds-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Binary Domain" href="/web/20121023121603/http://www.gameweb.fr/articles/test-45-binary-domain-ps3-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Catherine" href="/web/20121023121603/http://www.gameweb.fr/articles/test-43-catherine-x360-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" <a class="medium" title="Lire le test : Soulcalibur V" href="/web/20121023121603/http://www.gameweb.fr/articles/test-44-soulcalibur-v-ps3-page-opinion.html"></a>" & @CRLF & _
" <div class="separation" style="margin: 10px 0;"></div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" <footer id="main_footer"></footer>" & @CRLF & _
" </body>" & @CRLF & _
" </html>" & @CRLF & _
" <!--" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" FILE ARCHIVED ON 12:16:03 oct. 23, 2012 AND …" & @CRLF & _
"" & @CRLF & _
" -->" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")