using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""([^""]+)""";
string input = @" <!DOCTYPE html>
<html lang=""fr"">
<head></head>
<body>
<div id=""wm-ipp"" class="" lang=""en"" style=""display: block;""></div>
<!--
BEGIN WAYBACK TOOLBAR INSERT
-->
<script src=""/static/js/disclaim-element.js"" type=""text/javascript""></script>
<script src=""/static/js/graph-calc.js"" type=""text/javascript""></script>
<script src=""/static/jflot/jquery.min.js"" type=""text/javascript""></script>
<script type=""text/javascript""></script>
<style type=""text/css""></style>
<script type=""text/javascript""></script>
<!--
END WAYBACK TOOLBAR INSERT
-->
<header id=""main_header"">
<div class=""header_content""></div>
</header>
<div id=""main_content"">
<div id=""under_top_event""></div>
<div id=""breadcrumbs""></div>
<div id=""main_search""></div>
<div id=""content"">
<div id=""page_test"" class=""home"">
<div id=""topline"">
<h1>
TESTS
</h1>
</div>
<div class=""large_column left_column"">
<a class=""top"" title=""Lire le test : The Final Fantasy"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-65-the-final-fantasy-3ds-page-opinion.html""></a>
<div class=""separation"" style=""margin: 20px 0;""></div>
<a class=""high"" title=""Lire le test : El Shaddai : Ascension of The Metatron"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-63-el-shaddai-ascension-of-the-metatron-ps3-page-opinion.html""></a>
<a class=""high"" title=""Lire le test : Heroes of Ruin"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-62-heroes-of-ruin-3ds-page-opinion.html""></a>
<a class=""high"" title=""Lire le test : Prototype 2"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-61-prototype-2-ps3-page-opinion.html""></a>
<a class=""high"" title=""Lire le test : Rayman Origins"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-60-rayman-origins-ps3-page-opinion.html""></a>
</div>
<div class=""medium_column right_column"" style=""padding-top: 70px;"">
<a class=""medium"" title=""Lire le test : Mass Effect 3"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-59-mass-effect-3-x360-page-opinion.html"">
<span class=""small title""></span>
<span class=""put_score score""></span>
<span class=""description""></span>
</a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Pandora's Tower"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-58-pandoras-tower-wii-page-opinion.html"">
<span class=""small title""></span>
<span class=""put_score score""></span>
<span class=""description""></span>
</a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : I am alive"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-57-i-am-alive-x360-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Silent hill downpour"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-56-silent-hill-downpour-ps3-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Naruto Storm Generations"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-55-naruto-storm-generations-x360-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Street Fighter x Tekken"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-54-street-fighter-x-tekken-ps3-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Ninja Gaiden 3"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-53-ninja-gaiden-3-ps3-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Asura's Wrath"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-52-asuras-wrath-ps3-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : The Last Story"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-51-the-last-story-wii-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Xenoblade"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-50-xenoblade-wii-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : SSX"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-48-ssx-ps3-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Syndicate"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-47-syndicate-pc-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Resident Evil Revelations"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-46-resident-evil-revelations-3ds-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Binary Domain"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-45-binary-domain-ps3-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Catherine"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-43-catherine-x360-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
<a class=""medium"" title=""Lire le test : Soulcalibur V"" href=""/web/20121023121603/http://www.gameweb.fr/articles/test-44-soulcalibur-v-ps3-page-opinion.html""></a>
<div class=""separation"" style=""margin: 10px 0;""></div>
</div>
</div>
</div>
</div>
<footer id=""main_footer""></footer>
</body>
</html>
<!--
FILE ARCHIVED ON 12:16:03 oct. 23, 2012 AND …
-->
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}