$re = '/(?:(.)(?=(.*)\1))/im';
$str = 'sTress
lambda
moonmen';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;