package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*foo.*$`)
var str = `one line
second line
magic line foo
third line`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}