$re = '/^.*foo.*$/m';
$str = 'one line
second line
magic line foo
third line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);