$re = '~\p{Latin}+(?:\h*\p{Latin}+)*(?=\h*\p{Cyrillic}+)~m';
$str = 'Один два три apple orange yellow четыре пять black white';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);