const regex = /(^|#)9\|(([\d]+,)*4[,#])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|#)9\\|(([\\d]+,)*4[,#])', 'g')
const str = `7|1#9|1,5,7#10|2,4,51#
7|1#9|1,4,5#10|1,3,38#
7|1#19|1,14,5#10|1,3,38#
7|1#9|1,41,5#10|1,3,38#
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}