$re = '/(^|#)9\|(([\d]+,)*4[,#])/';
$str = '7|1#9|1,5,7#10|2,4,51#
7|1#9|1,4,5#10|1,3,38#
7|1#19|1,14,5#10|1,3,38#
7|1#9|1,41,5#10|1,3,38#
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);