$re = '/.*((social|(simple|free|floating)\-share)\-buttons\.com|e\-buyeasy\.com|wp(securitycheck|themedetector)\.co\.uk|erot\.co|webmonetizer\.net|howtostopreferralspam\.eu|trafficmonetizer?\.org|непереводимая\.рф|websites\-reviews\.com|sanjosestartups\.com|4webmasters\.org|aliexpress\.com|event\-tracking\.com|webmaster\-traffic\.com|vitaly|torture\.ml|amanda\-porn\.ga|generalporn\.org|\-porn\.ga|\-forum\.ga|\-free\-traffic\.ga|buy\-cheap\-online\.info|get\-free\-traffic\-now|googlsucks\.com|o\-o\.|humanorightswatch\.org|bestwebsitesawards\.com|resellerclub|smailik\.org|darodar\.com|hulfingtonpost\.com|blackhatworth\.com|(buttons|videos|buttons)\-for(\-your)?\-(website|business)\.com|success\-seo\.com|semalt|best\-seo\-(solution|offer)|dailyrank\.net|sitevaluation\.org|100dollars\-seo\.com|forum69\.info|7makemoneyonline\.com|anticrawler\.org|baixar\-musicas\-gratis\.com|descargar\-musica\-gratis\.net).*/i';
$str = 'site5.floating-share-buttons.com / referral
e-buyeasy.com / referral
wpsecuritycheck.co.uk / referral
wpthemedetector.co.uk / referral
erot.co / referral
webmonetizer.net / referral
howtostopreferralspam.eu / referral
trafficmonetizer.org / referral
wpsecuritycheck.co.uk / referral
wpthemedetector.co.uk / referral
trafficmonetize.org / referral
непереводимая.рф / referral
непереводимая.рф / organic
websites-reviews.com / referral
sanjosestartups.com / referral
4webmasters.org / referral
site1.floating-share-buttons.com
site3.floating-share-buttons.com
s.click.aliexpress.com/e/ay3rfmzfi /organic
www.event-tracking.com / referral
webmaster-traffic.com / referral
vitaly rules google / organic
torture.ml / referral
amanda-porn.ga / referral
generalporn.org / referral
depositfiles-porn.ga / referral
youporn-forum.ga / referral
site2.floating-share-buttons.com
rapidgator-porn.ga / referral
meendo-free-traffic.ga / referral
buy-cheap-online.info / referral
www.Get-Free-Traffic-Now.com / referral
addons.mozilla.org / referral
googlsucks.com / referral
simple-share-buttons.com / referral
social-buttons.com / referral
s.click.aliexpress.com / referral
o-o-8-o-o.com / referral
humanorightswatch.org / referral
o-o-6-o-o.com / referral
bestwebsitesawards.com / referral
resellerclub scam / organic
darodar.com / referral
hulfingtonpost.com / referral
ilovevitaly.com / referral
blackhatworth.com / referral
resellerclub scam / referral
forum20.smailik.org / referral
buttons-for-website.com
buttons-for-your-website.com
videos-for-your-business.com
success-seo.com
semaltmedia.com
dailyrank.net
sitevaluation.org
100dollars-seo.com
forum69.info
best-seo-solution.com
best-seo-offer.com
semalt.semalt.com
semalt.com
7makemoneyonline.com
anticrawler.org
baixar-musicas-gratis.com
descargar-musica-gratis.net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);