import re
regex = re.compile(r".*((social|(simple|free|floating)\-share)\-buttons\.com|e\-buyeasy\.com|wp(securitycheck|themedetector)\.co\.uk|erot\.co|webmonetizer\.net|howtostopreferralspam\.eu|trafficmonetizer?\.org|непереводимая\.рф|websites\-reviews\.com|sanjosestartups\.com|4webmasters\.org|aliexpress\.com|event\-tracking\.com|webmaster\-traffic\.com|vitaly|torture\.ml|amanda\-porn\.ga|generalporn\.org|\-porn\.ga|\-forum\.ga|\-free\-traffic\.ga|buy\-cheap\-online\.info|get\-free\-traffic\-now|googlsucks\.com|o\-o\.|humanorightswatch\.org|bestwebsitesawards\.com|resellerclub|smailik\.org|darodar\.com|hulfingtonpost\.com|blackhatworth\.com|(buttons|videos|buttons)\-for(\-your)?\-(website|business)\.com|success\-seo\.com|semalt|best\-seo\-(solution|offer)|dailyrank\.net|sitevaluation\.org|100dollars\-seo\.com|forum69\.info|7makemoneyonline\.com|anticrawler\.org|baixar\-musicas\-gratis\.com|descargar\-musica\-gratis\.net).*", flags=re.IGNORECASE)
test_str = ("site5.floating-share-buttons.com / referral\n"
"e-buyeasy.com / referral\n"
"wpsecuritycheck.co.uk / referral\n"
"wpthemedetector.co.uk / referral\n"
"erot.co / referral\n"
"webmonetizer.net / referral\n"
"howtostopreferralspam.eu / referral\n"
"trafficmonetizer.org / referral\n"
"wpsecuritycheck.co.uk / referral\n"
"wpthemedetector.co.uk / referral\n"
"trafficmonetize.org / referral\n"
"непереводимая.рф / referral\n"
"непереводимая.рф / organic\n"
"websites-reviews.com / referral\n"
"sanjosestartups.com / referral\n"
"4webmasters.org / referral\n"
"site1.floating-share-buttons.com\n"
"site3.floating-share-buttons.com\n"
"s.click.aliexpress.com/e/ay3rfmzfi /organic\n"
"www.event-tracking.com / referral\n"
"webmaster-traffic.com / referral\n"
"vitaly rules google / organic\n"
"torture.ml / referral\n"
"amanda-porn.ga / referral\n"
"generalporn.org / referral\n"
"depositfiles-porn.ga / referral\n"
"youporn-forum.ga / referral\n"
"site2.floating-share-buttons.com\n"
"rapidgator-porn.ga / referral\n"
"meendo-free-traffic.ga / referral\n"
"buy-cheap-online.info / referral\n"
"www.Get-Free-Traffic-Now.com / referral\n"
"addons.mozilla.org / referral\n"
"googlsucks.com / referral\n"
"simple-share-buttons.com / referral\n"
"social-buttons.com / referral\n"
"s.click.aliexpress.com / referral\n"
"o-o-8-o-o.com / referral\n"
"humanorightswatch.org / referral\n"
"o-o-6-o-o.com / referral\n"
"bestwebsitesawards.com / referral\n"
"resellerclub scam / organic\n"
"darodar.com / referral\n"
"hulfingtonpost.com / referral\n"
"ilovevitaly.com / referral\n"
"blackhatworth.com / referral\n"
"resellerclub scam / referral\n"
"forum20.smailik.org / referral\n"
"buttons-for-website.com\n"
"buttons-for-your-website.com\n"
"videos-for-your-business.com\n"
"success-seo.com\n"
"semaltmedia.com\n"
"dailyrank.net\n"
"sitevaluation.org\n"
"100dollars-seo.com\n"
"forum69.info\n"
"best-seo-solution.com\n"
"best-seo-offer.com\n"
"semalt.semalt.com\n"
"semalt.com\n"
"7makemoneyonline.com\n"
"anticrawler.org\n"
"baixar-musicas-gratis.com\n"
"descargar-musica-gratis.net")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")