const regex = /-\d*-\d*[.-]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\d*-\\d*[.-]', 'gm')
const str = `Ice Cold Murders- Rocco Schiavone-1-5.ts
Lost Girl---Where There's a Will, There's a Fae_Pick_2019_04_09_20_00.ts
Lost Girl-1-4-Food For Thought_Pick_2019_04_15_20_00.ts`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}