$re = '/-\d*-\d*[.-]/m';
$str = 'Ice Cold Murders- Rocco Schiavone-1-5.ts
Lost Girl---Where There\'s a Will, There\'s a Fae_Pick_2019_04_09_20_00.ts
Lost Girl-1-4-Food For Thought_Pick_2019_04_15_20_00.ts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);