#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\p{Cyrillic}0-9\s-#$%^&\\]+$"
Local $sString = "1 Май" & @CRLF & _
"-" & @CRLF & _
"Май 25\5" & @CRLF & _
"Ӑ ӑ" & @CRLF & _
"Ӓ ӓ" & @CRLF & _
"Ә ә" & @CRLF & _
"Ӛ ӛ" & @CRLF & _
"Ӕ ӕ" & @CRLF & _
"Б б" & @CRLF & _
"В в" & @CRLF & _
"Г г" & @CRLF & _
"Ґ ґ" & @CRLF & _
"Ѓ ѓ" & @CRLF & _
"Ғ ғ" & @CRLF & _
"Ӷ ӷ" & @CRLF & _
"Ҕ ҕ" & @CRLF & _
"Д д" & @CRLF & _
"Ђ ђ" & @CRLF & _
"Е е" & @CRLF & _
"Ѐ ѐ" & @CRLF & _
"Ё ё" & @CRLF & _
"Ӗ ӗ" & @CRLF & _
"Ҽ ҽ" & @CRLF & _
"Ҿ ҿ" & @CRLF & _
"Є є" & @CRLF & _
"Ж ж" & @CRLF & _
"Ӂ ӂ" & @CRLF & _
"Җ җ" & @CRLF & _
"Ӝ ӝ" & @CRLF & _
"З з" & @CRLF & _
"З́ з́" & @CRLF & _
"Ҙ ҙ" & @CRLF & _
"Ӟ ӟ" & @CRLF & _
"Ӡ ӡ" & @CRLF & _
"Ѕ ѕ" & @CRLF & _
"И и" & @CRLF & _
"Ѝ ѝ" & @CRLF & _
"Ӥ ӥ" & @CRLF & _
"Ӣ ӣ" & @CRLF & _
"І і " & @CRLF & _
"Ї ї" & @CRLF & _
"Ӏ ӏ" & @CRLF & _
"Й й" & @CRLF & _
"Ҋ ҋ" & @CRLF & _
"Ј ј" & @CRLF & _
"К к" & @CRLF & _
"Қ қ" & @CRLF & _
"Ҟ ҟ" & @CRLF & _
"Ҡ ҡ" & @CRLF & _
"Ӄ ӄ" & @CRLF & _
"Ҝ ҝ" & @CRLF & _
"Л л" & @CRLF & _
"Ӆ ӆ" & @CRLF & _
"Љ љ" & @CRLF & _
"М м" & @CRLF & _
"Ӎ ӎ" & @CRLF & _
"Н н" & @CRLF & _
"Ӊ ӊ" & @CRLF & _
"Ң ң" & @CRLF & _
"Ӈ ӈ" & @CRLF & _
"Ҥ ҥ" & @CRLF & _
"Њ њ" & @CRLF & _
"О о" & @CRLF & _
"Ӧ ӧ" & @CRLF & _
"Ө ө" & @CRLF & _
"Ӫ ӫ" & @CRLF & _
"Ҩ ҩ" & @CRLF & _
"П п" & @CRLF & _
"Ҧ ҧ" & @CRLF & _
"Р р" & @CRLF & _
"Ҏ ҏ" & @CRLF & _
"С с" & @CRLF & _
"С́ с́" & @CRLF & _
"Ҫ ҫ" & @CRLF & _
"Т т" & @CRLF & _
"Ҭ ҭ" & @CRLF & _
"Ћ ћ" & @CRLF & _
"Ќ ќ" & @CRLF & _
"У у" & @CRLF & _
"Ў ў " & @CRLF & _
"Ӳ ӳ" & @CRLF & _
"Ӱ ӱ" & @CRLF & _
"Ӯ ӯ" & @CRLF & _
"Ү ү" & @CRLF & _
"Ұ ұ" & @CRLF & _
"Ф ф" & @CRLF & _
"Х х" & @CRLF & _
"Ҳ ҳ" & @CRLF & _
"Һ һ" & @CRLF & _
"Ц ц" & @CRLF & _
"Ҵ ҵ" & @CRLF & _
"Ч ч" & @CRLF & _
"Ӵ ӵ" & @CRLF & _
"Ҷ ҷ" & @CRLF & _
"Ӌ ӌ" & @CRLF & _
"Ҹ ҹ" & @CRLF & _
"Џ џ" & @CRLF & _
"Ш ш" & @CRLF & _
"Щ щ" & @CRLF & _
"Ъ ъ" & @CRLF & _
"Ы ы" & @CRLF & _
"Ӹ ӹ" & @CRLF & _
"Ь ь" & @CRLF & _
"Ҍ ҍ" & @CRLF & _
"Э э" & @CRLF & _
"Ӭ ӭ" & @CRLF & _
"Ю ю" & @CRLF & _
"Я я" & @CRLF & _
"abcdefgh" & @CRLF & _
"012344"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")