import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\p{Cyrillic}0-9\\s-#$%^&\\\\]+$";
final String string = "1 Май\n"
+ "-\n"
+ "Май 25\\5\n"
+ "Ӑ ӑ\n"
+ "Ӓ ӓ\n"
+ "Ә ә\n"
+ "Ӛ ӛ\n"
+ "Ӕ ӕ\n"
+ "Б б\n"
+ "В в\n"
+ "Г г\n"
+ "Ґ ґ\n"
+ "Ѓ ѓ\n"
+ "Ғ ғ\n"
+ "Ӷ ӷ\n"
+ "Ҕ ҕ\n"
+ "Д д\n"
+ "Ђ ђ\n"
+ "Е е\n"
+ "Ѐ ѐ\n"
+ "Ё ё\n"
+ "Ӗ ӗ\n"
+ "Ҽ ҽ\n"
+ "Ҿ ҿ\n"
+ "Є є\n"
+ "Ж ж\n"
+ "Ӂ ӂ\n"
+ "Җ җ\n"
+ "Ӝ ӝ\n"
+ "З з\n"
+ "З́ з́\n"
+ "Ҙ ҙ\n"
+ "Ӟ ӟ\n"
+ "Ӡ ӡ\n"
+ "Ѕ ѕ\n"
+ "И и\n"
+ "Ѝ ѝ\n"
+ "Ӥ ӥ\n"
+ "Ӣ ӣ\n"
+ "І і \n"
+ "Ї ї\n"
+ "Ӏ ӏ\n"
+ "Й й\n"
+ "Ҋ ҋ\n"
+ "Ј ј\n"
+ "К к\n"
+ "Қ қ\n"
+ "Ҟ ҟ\n"
+ "Ҡ ҡ\n"
+ "Ӄ ӄ\n"
+ "Ҝ ҝ\n"
+ "Л л\n"
+ "Ӆ ӆ\n"
+ "Љ љ\n"
+ "М м\n"
+ "Ӎ ӎ\n"
+ "Н н\n"
+ "Ӊ ӊ\n"
+ "Ң ң\n"
+ "Ӈ ӈ\n"
+ "Ҥ ҥ\n"
+ "Њ њ\n"
+ "О о\n"
+ "Ӧ ӧ\n"
+ "Ө ө\n"
+ "Ӫ ӫ\n"
+ "Ҩ ҩ\n"
+ "П п\n"
+ "Ҧ ҧ\n"
+ "Р р\n"
+ "Ҏ ҏ\n"
+ "С с\n"
+ "С́ с́\n"
+ "Ҫ ҫ\n"
+ "Т т\n"
+ "Ҭ ҭ\n"
+ "Ћ ћ\n"
+ "Ќ ќ\n"
+ "У у\n"
+ "Ў ў \n"
+ "Ӳ ӳ\n"
+ "Ӱ ӱ\n"
+ "Ӯ ӯ\n"
+ "Ү ү\n"
+ "Ұ ұ\n"
+ "Ф ф\n"
+ "Х х\n"
+ "Ҳ ҳ\n"
+ "Һ һ\n"
+ "Ц ц\n"
+ "Ҵ ҵ\n"
+ "Ч ч\n"
+ "Ӵ ӵ\n"
+ "Ҷ ҷ\n"
+ "Ӌ ӌ\n"
+ "Ҹ ҹ\n"
+ "Џ џ\n"
+ "Ш ш\n"
+ "Щ щ\n"
+ "Ъ ъ\n"
+ "Ы ы\n"
+ "Ӹ ӹ\n"
+ "Ь ь\n"
+ "Ҍ ҍ\n"
+ "Э э\n"
+ "Ӭ ӭ\n"
+ "Ю ю\n"
+ "Я я\n"
+ "abcdefgh\n"
+ "012344";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}