using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(
( # GENERAL before . (Dot)
(?!\w+\?) # DO NOT MATCH if contains ?
[\w\]\)]+ # Word, ] or ) characters 1 or more times
)|
(?:\((\w+)\))| # BRACKETS ()
([\w\]\)]+(?![?*+])) # BEFORE . (Dot) with ?, * or +
)";
string input = @"abcdef.*g[0abc]{0,5}hi # abcdef
]1234vac.*12345 # ]1234vac
)1234vac.*12345 # )1234vac
(abc)+123 # abc
12345[abcde]+12345 # 12345
123?456 # 12
123\?456 # 123?456
# --- No Prefix ---
[A-z]+12345
(1234vac.*12345
[a-z]+";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}