# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(
( # GENERAL before . (Dot)
(?!\w+\?) # DO NOT MATCH if contains ?
[\w\]\)]+ # Word, ] or ) characters 1 or more times
)|
(?:\((\w+)\))| # BRACKETS ()
([\w\]\)]+(?![?*+])) # BEFORE . (Dot) with ?, * or +
)
"""
test_str = ("abcdef.*g[0abc]{0,5}hi # abcdef\n"
"]1234vac.*12345 # ]1234vac\n"
")1234vac.*12345 # )1234vac\n"
"(abc)+123 # abc\n\n"
"12345[abcde]+12345 # 12345\n"
"123?456 # 12\n"
"123\\?456 # 123?456\n\n\n\n"
"# --- No Prefix ---\n\n"
"[A-z]+12345\n"
"(1234vac.*12345\n"
"[a-z]+")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.