#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\d{4}(\s[1-9]\d{0,3}){2}(\s\d{1,4}){0,2})|(\d{9}\s[1-9]\d{0,3}))$"
Local $sString = "987654321 1" & @CRLF & _
"987654321 21" & @CRLF & _
"0101 9 1" & @CRLF & _
"1701 91 1 2" & @CRLF & _
"4101 917 1 0 43" & @CRLF & _
"0801 9 178 2 0" & @CRLF & _
"0111 9 1 084 0" & @CRLF & _
"" & @CRLF & _
"0101 9 1 0 1 0" & @CRLF & _
"3124" & @CRLF & _
"0314 9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")