re = /^((\d{4}(\s[1-9]\d{0,3}){2}(\s\d{1,4}){0,2})|(\d{9}\s[1-9]\d{0,3}))$/m
str = '987654321 1
987654321 21
0101 9 1
1701 91 1 2
4101 917 1 0 43
0801 9 178 2 0
0111 9 1 084 0
0101 9 1 0 1 0
3124
0314 9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end