using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?im)^\D*(\d+(?:[- ][a-z ]*[a-z])?)";
string input = @"FOO 288-B BAR <MATCH: ""288-B BAR"">
BURT 69/ERNIE 96/KERMIT 287 <MATCH: ""69"">
53 ORANGE <MATCH: ""53 ORANGE"">
APPLE 457-W <MATCH: ""457-W"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}