import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?im)^\\D*(\\d+(?:[- ][a-z ]*[a-z])?)";
final String string = "FOO 288-B BAR <MATCH: \"288-B BAR\">\n"
+ "BURT 69/ERNIE 96/KERMIT 287 <MATCH: \"69\">\n"
+ "53 ORANGE <MATCH: \"53 ORANGE\">\n"
+ "APPLE 457-W <MATCH: \"457-W\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}