#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)[0-9]+(?=\.html)"
Local $sString = "http://ewrf3w.com/ewerwe234.html"
Local $sSubst = "3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)