$re = '/[0-9]+(?=\.html)/i';
$str = 'http://ewrf3w.com/ewerwe234.html';
$subst = "3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;